September 5, 2012

Localytics Library Updated for Apple iOS 6

Share

Localytics today launched an updated iOS library for improved compatibility with Apple’s upcoming iOS 6.  All customers are required to upgrade to this latest Localytics library before making new App Store submissions. Apps already in the App Store that are using an earlier version of the Localytics iOS library are still compatible with devices upgraded to iOS 6, but will need the updated SDK when a new release is submitted.

Localytics now uses the new identifierForAdvertising provided by Apple in iOS 6 to ensure that anonymous unique users, retention reports and other analyses are accurate and consistent for all iPhone and iPad apps. The Unique Device Identifier (UDID), which was deprecated but still available in iOS 5, is no longer used by Localytics in iOS 6. This transition will be managed by Localytics to avoid the appearance of “new” users resulting from upgrades to  iOS 6.

If you are upgrading from an older 2.x version of the SDK, simply replace the Localytics source files in your project with the updated SDK. A complete integration guide and the latest Localytics library for iOS 6 are available for immediate use.

Author

Posted in Company & Products
Share this
Share